Trust Reports

Independent Trust Reports for public GitHub repos — security, code quality, license, and completeness scored 0–100. Maintainers can claim their listing in 30 seconds.

Verify a repoFree · 25 seconds · No login
5461
indexed
2255
verified
2
claimed

Top scoring · Verified

Showing 48 of 3110 reports in Software.
75lb
wordwrapjs
97VERIFIED

Word-wrapping for javascript.

Software
161JavaScript
View Trust Report
sindresorhus
ky
97VERIFIED

🌳 Tiny & elegant JavaScript HTTP client based on the Fetch API

Software
17.1kTypeScript
View Trust Report
unjs
citty
97VERIFIED

🌆 Elegant CLI Builder

Software
1.3kTypeScript
View Trust Report
dubzzz
fast-check
97VERIFIED

Property based testing framework for JavaScript (like QuickCheck) written in TypeScript

Software
5.2kTypeScript
View Trust Report
reduxjs
react-redux
97VERIFIED

Official React bindings for Redux

Software
23.4kTypeScript
View Trust Report
remarkablemark
style-to-object
97VERIFIED

📝 Parse CSS inline style to JavaScript object.

Software
76TypeScript
View Trust Report
reduxjs
redux
97VERIFIED

A JS library for predictable global state management

Software
61.5kTypeScript
View Trust Report
microsoft
playwright
97VERIFIED

Playwright is a framework for Web Testing and Automation. It allows testing Chromium, Firefox and WebKit with a single API.

Software
97.5kTypeScript
View Trust Report
floating-ui
floating-ui
97VERIFIED

A JavaScript library to position floating elements and create interactions for them.

Software
32.8kTypeScript
View Trust Report
vitest-dev
vitest
97VERIFIED

Next generation testing framework powered by Vite.

Software
17.2kTypeScript
View Trust Report
jshttp
vary
97VERIFIED

Manipulate the HTTP Vary header

Software
65JavaScript
View Trust Report
pillarjs
send
97VERIFIED

Streaming static file server with Range and conditional-GET support

Software
811JavaScript
View Trust Report
websockets
ws
97VERIFIED

Simple to use, blazing fast and thoroughly tested WebSocket client and server for Node.js

Software
22.8kJavaScript
View Trust Report
Eliot-Abramo
Kicad-Multi-PCB
97VERIFIED

KiCad Action Plugin for managing multiple PCBs (“sub-boards”) from a single schematic (KiCad 10+).

Software
16Python
View Trust Report
tobymao
sqlglot
97VERIFIED

Python SQL Parser and Transpiler

Software
9.4kPython
View Trust Report
SecurityRonin
alaya
97VERIFIED

A memory engine for conversational AI agents, inspired by neuroscience and Buddhist psychology

Software
14Rust
View Trust Report
UseJunior
safe-docx
97VERIFIED

Safe DOCX suite: docx-primitives, docx-comparison, safe-docx MCP server

Software
36TypeScript
View Trust Report
debug-js
debug
97VERIFIED

A tiny JavaScript debugging utility modelled after Node.js core's debugging technique. Works in Node.js and web browsers

Software
11.5kJavaScript
View Trust Report
sindresorhus
is-obj
97VERIFIED

Check if a value is an object

Software
42JavaScript
View Trust Report
dphilipson
typescript-fsa-reducers
96VERIFIED

Fluent syntax for defining typesafe reducers on top of typescript-fsa.

Software
221TypeScript
View Trust Report
bendrucker
http-status-emojis
96VERIFIED

Emojis for HTTP status codes

Software
26JavaScript
View Trust Report
alexcanessa
typescript-coverage-report
96VERIFIED

Node command tool to generate TypeScript coverage report

Software
524TypeScript
View Trust Report
Mitcheljager
svelte-confetti
96VERIFIED

Confetti in Svelte! Celebrate things with some extra flair. Animates using just HTML and CSS meaning it can work with SSR in SvelteKit!

Software
319Svelte
View Trust Report
Redocly
redoc
96VERIFIED

📘 OpenAPI/Swagger-generated API Reference Documentation

Software
26.0kTypeScript
View Trust Report
posva
focus-trap-vue
96VERIFIED

Vue component to trap the focus within a DOM element

Software
217JavaScript
View Trust Report
mattjennings
svelte-modals
96VERIFIED

A simple, flexible, zero-dependency modal stack manager for Svelte.

Software
165TypeScript
View Trust Report
vitalets
websocket-as-promised
96VERIFIED

A Promise-based API for WebSockets

Software
601JavaScript
View Trust Report
unplugin
unplugin-vue
96VERIFIED

✨ Transform Vue 3 SFC to JavaScript. Supports Vite, esbuild, Rollup, Webpack and more.

Software
274TypeScript
View Trust Report
Justineo
vue-clamp
96VERIFIED

Clamping primitives for Vue.

Software
842TypeScript
View Trust Report
ValentinH
svelte-easy-crop
96VERIFIED

A Svelte component to crop images with easy interactions

Software
256TypeScript
View Trust Report
adopted-ember-addons
ember-cli-flash
96VERIFIED

Simple, highly configurable flash messages for ember-cli

Software
354TypeScript
View Trust Report
0x31
vite-plugin-graphql-loader
96VERIFIED

A Vite plugin for loading GraphQL files.

Software
25TypeScript
View Trust Report
ota-meshi
stylelint-config-standard-vue
96VERIFIED

The standard shareable Vue config for Stylelint.

Software
27JavaScript
View Trust Report
CookPete
auto-changelog
96VERIFIED

Command line tool for generating a changelog from git tags and commit history

Software
1.4kJavaScript
View Trust Report
sveltejs
svelte-preprocess
96VERIFIED

A ✨ magical ✨ Svelte preprocessor with sensible defaults and support for: PostCSS, SCSS, Less, Stylus, Coffeescript, TypeScript, Pug and much more.

Software
1.8kTypeScript
View Trust Report
tree-sitter
tree-sitter-typescript
96VERIFIED

TypeScript grammar for tree-sitter

Software
534JavaScript
View Trust Report
tree-sitter
tree-sitter-javascript
96VERIFIED

Javascript grammar for tree-sitter

Software
495JavaScript
View Trust Report
huntabyte
bits-ui
96VERIFIED

The headless components for Svelte.

Software
3.6kTypeScript
View Trust Report
3846masa
http-cookie-agent
96VERIFIED

Allows cookies with every Node.js HTTP clients (e.g. Node.js global fetch, undici, axios, node-fetch).

Software
53TypeScript
View Trust Report
chmln
flatpickr
96VERIFIED

lightweight, powerful javascript datetimepicker with no dependencies

Software
16.5kTypeScript
View Trust Report
expressjs
method-override
96VERIFIED

Override HTTP verbs.

Software
627JavaScript
View Trust Report
josdejong
typed-function
96VERIFIED

Runtime type-checking for JavaScript functions

Software
79JavaScript
View Trust Report
mafintosh
queue-tick
96VERIFIED

Next tick shim that prefers process.nextTick over queueMicrotask for compat

Software
9JavaScript
View Trust Report
jorgebucaran
getopts
96VERIFIED

Node.js CLI options parser

Software
634JavaScript
View Trust Report
expressjs
cookie-parser
96VERIFIED

Parse HTTP request cookies

Software
2.0kJavaScript
View Trust Report
prettymuchbryce
http-status-codes
96VERIFIED

Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.

Software
1.1kTypeScript
View Trust Report
styled-components
css-to-react-native
96VERIFIED

Convert CSS text to a React Native stylesheet object

Software
1.2kTypeScript
View Trust Report
DmitrySoshnikov
regexp-tree
96VERIFIED

Regular expressions processor in JavaScript

Software
426JavaScript
View Trust Report